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WinTool Interface 1.4.6 for TopSolid'Cam 7

The WT-TopSolidCam-Interface enables the user to select and transfer tool assemblies
from the WinTool database to the TopSolid'Cam environment.

After production of a NC program, a complete list of the tools used in the NC-Program
will be stored back to the WinTool database for further processing in the company.
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Summary
Job

The WT-TopSolidCam-Interface enables the user to export all assemblies from the WinTool database into
the TopSolid environment. Full graphic representation with tool holders and extensions are supported.

After production of a NC program, a complete list of the tools used in the NC-Program will be stored back to
the WinTool database for further processing in the company.

Requirements

This Interface requires WinTool Professional 2011 or newer. TopSolid'‘Cam 7.12 and 7.13 are supported.

Licensing

You need a license agreement with WinTool AG, Switzerland.

Copyright

This documentation as well as the Software itself is under copyright of

WinTool AG

Flielastrasse 7

CH-8048 Ziirich

Phone: +41 (0)44 401 00 55
info@wintool.com
http://www.wintool.com
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Installation

Directory Structure

All user data is centrally placed the [Public Documents]\WT-TopSolidCam-Interface folder:

User data Location

Default location of UserModels [Public Documents]\WT-TopSolidCam-Interface\UserModels
folder

Default location of Exchange folder | [Public Documents]\WT-TopSolidCam-Interface\Exchange
Configuration file [Public Documents]\WT-TopSolidCam-Interface
WT-TopSolidCam-Interface.cfg

Note: [Public Documents] on Windows XP is located in C:\Documents and Settings\All Us-
ers\Documents on Windows Vista and newer in C:\Users\Public\Documents\

New Installation

Log on with administrator rights to install the software on a PC. Install WinTool Professional first before you
install the WT-TopSolidCam-Interface.

Download the latest WT-TopSolidCam-Interface software release from www.WinTool.com and start
Setup.exe.

Follow the instructions in chapter Configure WT-TopSolidCam-Interface and Configure TopSolid'Cam

Update

Download the latest WT-TopSolidCam-Interface software release from www.WinTool.com and start
Setup.exe.

Follow the instructions in chapter Configure TopSolid'Cam

Open the interface configuration via "Start" > "All Programs" > "WinTool" > "WT-TopSolidCam-Interface" >
"WT-TopSolidCam-Interface Configuration" and check the settings.
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Configure WT-TopSolidCam-Interface

The configuration window allows you to check and change the settings of the WT-TopSolidCam-Interface.
Open the configuration window via "Start" > "All Programs" > "WinTool" > "WT-TopSolidCam-Interface ..."
> WT-TopSolidCam Configuration”

Path settings: Click on
the icon to select a di-
| rectory via browser or
en\t\er path manually

Settings
Name: Value A/ \
ouparar | > %]
| UserModelsPath D:ACAMY [ ]
| | Description s.Nr] [Tools. Descript] /
Coveal Mmber -
Settings not with de- ToollD The error icon @ indi-
fault values are white. ListName cates a faulty value in
Settings with default BmMNumber MNC ProgramMumber the Cfg file. If it appears
values are gray escription ToolList Description the setting.must be
checked
Details on selected setting
Default OutputPath is " Exchange” folder in local path
Comments /V
about the data
field settings

0K Cancel

<OK> stores all settings. <Cancel> exits the configuration window without saving.

The configuration window reads and stores settings in the file “WT-TopSolidCam-Interface.cfg” which is lo-
cated in the directory [Public Documents]\WT-TopSolidCam-Interface. This file can also be edited
with a text editor.

Output Path
The Output Path defines the directory for the data exchanges.

This directory must not be shared by multiple users because the data transferred via this directory is NC pro-
ject specific and temporary only.

The default settings are:
OutputPath = [Public Documents] \WT-TopSolidCam-Interface\Exchange\

UserModels Path

The UserModels directory manages the transfer of tool contour graphics (DXF). WinTool links and manages
these models and all NC programmers must access and share this data.

If you have multiple NC programmers you must create a UserModels folder on the server. It must be in-
cluded in the backup schedule.

The default settings are:
UserModelsPath = [Public Documents]\WT-TopSolidCam-Interface\UserModels\
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Description

As in TopSolid the Description is used to better identify tools, the interface makes it configurable how the De-
scription is generated while importing Tool assemblies from WinTool, making imports more flexible. It is up to
the user to define a custom naming convention. The interface, however, will provide a default convention
which is backward compatible with older TopSolid Interface installations. With the new TopSolid Interface 1.4
(and newer) placeholders (put in square brackets) can be used to modify the Description. Most Tool values
made in WinTool are supported. A short list of supported placeholders:

Tools.Nr, Tools.TNumber, Tools.Comment, Tools.Name, Tools.MachineNr, Tools.Descript,
Tools.Design, Tools.MaskNr, Tools.ToolWidth, Tools.ToolLength, Tools.OldName, Tools.MDate,
Tools.StockState

Tool assemblies o @ x
(1) ~ ﬂ‘ = ﬂ muxfE V. £
(= .
O 2] mu-fy B
Nawigabon Search Record Assembly Functons
Descrphion|  Tools.Description | Ident No || Tools r |
Design | Toois. Design | T-No | Tools. TNumber |
Cuttertype HSS Machine type | 01 Taper - SK40
A Code | Tools OldNams | Tool class || Tools.Name |

Graphic Geometry AD Bill of matenials CAM | Presetting
2D Shape STEP STL JPG

174

154.9

N\ K

I C— %Ia
=
A
STL A =2H
e /=T STEP VE=)

A

Special placeholders with dependent meanings:
e TNumber — (without Tools prefix) will become T from Lists if a list is imported, otherwise T from Tools if a
tool is imported.

Important Notes:

e Placeholders have to be put in square brackets.
e Parameter Description is limited by TopSolid to 266 characters.

Example:
A setting like
[Tools.Nr] - [TNumber] - [Tools.Descript]

could be translated to
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616021 - 0 - End Mill HSS 4x19 4FL
if imported via Tool assembly, or to
616021 - 123 - End Mill HSS 4x19 4FL

when imported via Tool list.

ComplementaryPartNumber / PartNumber

ToollD and T-Number are now completely configurable. In these 2 options you can select if you want the
them to have the ToollD/T-Number or also be empty.

The default values are:
ComplementaryPartNumber — T-Number
ParNumber - ToollD

Note:
e ToollD must always be defined in one of them.

NCProgramNumber / ToolListDescription

These configurations are used for the Export of a Tool into WinTool with the PUT button. In which you can
choose what you decide to export to these two fields. You have the choice between 4 options:

e ListName

e NCProgramNumber
e ToolListDescription
e Empty

ImportToolsToPocket

This configuration is used to Import the Tools directly into the Pocket list in TopSolid, if set to “True” it will im-
port it directly into the “WinTool Tools” library and into the Pocket list. If set to “False” it will only import it in
the “WinTool Tools” library.

T

iz List tool
| §
| I H I 4
” { ] i | v =x | 3}
Spotting Drill | Center Drill  Twist Drill Flat Drill Gun Drill  Countersin..  Face Mill Side Mill Slot Mill T Slot Mill
< >
H { © H_:-' X Wintool ~ All Tool Holders v
| Pocket P. D L r Description &
O 6.8mm 73mm Omm 616004 Twist Drill HSS 6.8x69
|z 100mm Fmm 0.5mm 616093 Face Mil 100x3 43° 7FL
HImRE] 63mm 40mm Omm 616100 Shell Mill HSS 63x40 BFL
|4 100mm 4mm Omm 616102 Disc Miling Cutter 1004 6FL
s 32mm 10mm Omm 616101 T-Slot End Mill HSS 32¢10 6FL
Has 32mm 15mm Imm E16097 Square Shoulder Mill 32x15 3FL
a7 10mm 22mm 5mm 616040 Ball Nose End Mill HSS 10x22 2FL
(Rt 4mm 12mm Omm 616103 Spot Dril HSS 4x12 1307
(Rt 10mm 13mm 5mm 616122 Bull Nose End Mil HSS 10x13 R2 2FL
110 6.8mm 73mm Omm 616004 Twist Drill HSS 6.8x69
O
Ol
[ARE]
|4
|5
/|6
|17
)18
[MERE]
20 &
< >
v x?
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Configure TopSolid'Cam

To access the WT-TopSolidCam import and export quickly, add the buttons to TopSolid'Cam:

For TopSolid 7.11 and older

e Open a machining project in TopSolid'Cam
e Select "Tools" > "Customize"

For TopSolid 7.12 and newer
e Open a machining project in TopSolid'Cam

e Select "Tools" > press the “Menu” I? button > press “Add” and add a menu with the name of your
choice
¢ In the machining project select the created Menu

Import Button

1. In"Add a file to execute", click on "..."
- Go to the WT-TopSolidCam-Interface installation directory and open the directory "7.11" or "7.12"
- Select "WT-TopSolidCAM-GetTools.exe"

2. Drag and Drop the "WT-GET" icon into a toolbar "Equipment"

Export Button

1. In"Add a file to execute", click on "..."
- Go to the WT-TopSolidCam-Interface installation directory and open the directory "7.11" or "7.12"
- Select "WT-TopSolidCAM-PutToolList.exe"

2. Drag and Drop the "WT-PUT" icon into the toolbar "Equipment"

8 Home | <@ Equipment ¥ & 2D/3D ¥ | 4, 4D/5D ¥ @ Tumning ¥ @] Additional ¥ |%¥Operation ¥ | Verify | ImalVisualization J

4494 &80

NC Operations

LY | Start Page || Wintool-TopSolid-Demo-Start-1-Result

@ Customize

| Toolbars || Shortcut keys l\

E‘a Clamping: Drag-and-drop commands between thtoolbars, or from the lists below...
g
; Command category:

’AII Categories '] Add user context

Add commands:

- Right-cli
(3D Contouring... (20/3D) rename it
(;4)( Radial Roughing... (4D/3D) Drag-and-driye a user context to change its position,
4/ 50 Contouring... (40/50)

[/ About TopSelid... (Global)
T Add-ins... (Operation) Rolling lists
T Add-ins... (Tools) o
1 Adjust Continuity... (Surface » ¢ Add rolling list

-+ Alignment... (30 Sketch > Const D

++ Alignment... (20 Sketch > Const

7 Ambient Light... (Visualization >
i Analysis of drillings and cylinde Add a file to execute
[ Analyze Area Moments of Inertii
#r Analyze Continuity... (Tools » 4| Path of file to execute:
"‘}i Analyze Curvature... (Tools » Ar
??Analyze Enumeration... (Tools »
.-:‘,_“‘Analyze Face Type... (Tools » Ar
7 Analyze Geometry... (Tools > Ar,
L Analyze Normal... (Tools » Anal
 Analyze Physical Properties... (T
??%Analyze User Enumeration... (To

a user context to modify its icon/name, double-click to

Separators

Add separator:

R

Interface'\WT-ToolExport.exe

Command name: WT-ToolExport

Drag-and-drop icon:

Display commands on document
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Supported TopSolid'Cam Tool Types

Each tool classification in WinTool must be assigned to the corresponding TopSolid'Cam tool type.
This is done automatically when you import tool assemblies.

You can modify the assignment manually:
In WinTool select Settings > Class, then select a classification. In the data field "Note" you can assign the

corresponding TopSolid'Cam tool type.
[@ Classes

Search by
| Cassification ||

Description |

Description |422 countersinks

Codes for CAM [/VCO1 /CAT{,/TC1S

Assigned to | 42 courterbore

TopSolid'Cam Tooltype WinTool
Deutsch | English Classification
Anbohrer Spotting Drill /TCO1
Zentrierbohrer Center Dirill /TCO02
Spiralbohrer Twist Drill /TCO3
Flachbohrer Flat Drill /TCO04
Tieflochbohrer Gun Drill /TCO05
Planfraser Face Mill /TCO06
Schaftfraser Side Mill /TCO7
Langlochfraser Slot Mill /TCO8
T-Nutfraser T Slot Mill /TCO9
Eckradienfraser Radiused Mill /TC10
Radienfraser BallNose Mill /TC11
Kugelkopffraser Lollipop Mill ITC12
Konischer Fraser Conic Nose Mill /TC13
Konischer Radiusfréaser Conic Nose Ball Mill /TC14
Senkfréser Spot Face Mill /TC15
Bohren von konischer Senkung Countersink Drill /ITC16
Senkbohrer Counterboring Mill /TC17
Radiusfraser Corner Rounding Mill /TC18
Fasenfraser Chamfer Mill /TC19
Umgekehrter Fasenfréaser Reverse Chamfer Mill /TC20
Doppelter Fasenfraser Double Chamfer Mill /TC21
Scheibenfraser Disc Mill ITC22
T-Nut-Rundungsfraser Radiused Staggered Teeth Mill /TC23
Hochvorschubfréaser High Feed Face Mill ITC24
Reibahle Constant Reamer ITC25
Ausdrehwerkzeug Boring Bar /TC26
Gewinde Tap ITC27
WT-TopSolidCam-Interface-Manual-E.docx 10.06.2021 Page 10/24
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Ruickwartssenker Back Spot Face Mill ITC28
Innengewindefraser Internal Thread Mill ITC29
Kugelsonde BallTouch /TC30
Aussendrehmeissel External Turn /TC31
Innendrehmeissel Internal Turn ITC32
Aussennutmeissel External Groove /TC33
Innennutmeissel Internal Groove /ITC34
Radialnutmeissel Frontal Groove /TC35
Aussengewinde External Thread /TC36
Innengewinde Internal Thread /TC37
AuRengewindefraser External Thread Mill /TC38
Ovalerfraser Oval Mill /TC40
Linsenfraser Lens Mill /TC41

Ignore /TCO0

WinTool classifications mapped to /TCO0 are ignored. This means that tools assigned to this classification are
not transferred to TopSolid'Cam. This is useful for measurement equipment, fixtures, etc.

Cutting Conditions

As of TopSolid 7.11 SP12 WinTool has a plugin that can be bought separately (Missler license 3711). With
this plugin, cutting Conditions can be imported directly from WinTool just by a click of a button on the Cutting

Conditions Window in TopSolid:

616004 Twist Drill HSS 6.6x69 #/616004|
Number of Teeth: 2

Cutting conditions ” Gauges ‘

44 Units

@ Metric
» Cutting conditions

Spindle rate tool [n)
9362Upm
F_ Feed rate (vf)

9362mm/min

O Imperial

|2, Abacus End Milling\Mills\HSS\ (NO MATERIAL)

Cutting speed (vc)
200m/min

Tooth feed rate (f2)
0.5mm/Zahn

F_ Teol feed rate (fz x 7)

Coolant mode TmmAu
None v

[ Tooth feed rate (f2) locked

F” Feed rate ISO output

»

WinTool

@® VEimm/min) O f mm/re)
S Machine (NC Machine 1) &
Max spindle rate T Max feed rate
=30000Upm =1000000mem/min
Cutting conditions documents:
NO MATERIAL v
Choose an Abacus for Reading:
[ abacus End Milling\MilisiHss\ “
=Y [:' Apply selected Abacus
Save Conditions For :
616004 Twist Drill HSS 6,869 2/616004|

Assembly cutting conditions

Tool assembly: 616004 Twist Drill HSS 6.8¢69
DMC  Sthr ap ae Dia Ve fz 5 F Type Coolant type P
0 7 1273 199
mnm 1.1545* |60 0 6.3 1 14 0121 655 73 20n 1]
712 |3.0506% |60 ] 63 1 70 0248 3277 813 20n a
< >
ap ae D Vo fz 5 F PikW) T .
60 ] 7 1 28 0156 1273 159 0 Os =
= 122 |General structural steel “unalloyed more than 500 N/mm? @
Remark Standard | ~ | 20n | - inch [] =
g
| OK | | Cancel ‘ | Abort | 0

To enable import of cutting conditions you will have to copy the file
WinToolAG.WTTopSolidCAM. Plugin.dll from the installation
folder of the interface to the bin folder of your TopSolid installation.
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Importing Tool Assemblies

Note: The "TopSolid Machining" library must be in the PDM.

Open a machining project. Start the import by clicking on the WT-GET button.
The following WT-ToolExport menu will open:
(@ WT-ToolExport m =)

Tool list Machine

P

Select the icon for tool assembly to import tools individually or for tool list to load an existing WinTool tool list.
If you know the tool assembly ID or tool list name, you can fill in the value and hit enter on your keyboard.

Tool assembly

-

The tools will immediately be transferred. Click on to open the tool classification tree. Select and highlight
the desired tool.

g B
(@ Search for assembly EIM
221 face mil - = Machine type Al
State Al
With cutting conditions for | 712 Aluminium “ Wrough alloy not aged Al
Only
I prered
DMC Clength CRadius Chrc LColl  ID & Descript Design
50 10 05 43 70 Q face mil R220.43 50mm OFEX 05T305
85 ] i
43 0
85 0
100 7 05 43 ] 616093 face mil RZ‘ZD SQqy OFEX 057305 I
100 15 3 85 ] 616094 end mill edging R220.63 = = B
50 15 3 5 70 §16095 end mill edging Rz‘zoeaf;r Class [E=
Graphic | Data | Cutting conditions Select one from each list
1_drilling 21 end mil 221 face mil
150 T — 222 square shoulder cutter
3 tap 24 other mills 223 chamfer mill
130.9 4 reamer, ¢ bore 25 inch end mil 224 disc mil
5 modular system 26 inch insert mill
& tuming toal 27 inch other mills
7 inserts
8 haolder
9 other
A measuring equip.
B clamping equip.
Il C
-
o
=7 T \ ‘
(S

There are filters available for machine type, tool data release state, cutting conditions for different materials,
and preferred tools. You can also enter commands (>, <, >=, <=) to filter a list of tools:

- [+
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e .
The function turns on combo box selection for the tool values:

DMC [&] CL.. ] CR.. [¢] CAc [¢] LCol 5] ID [] Descript [¢] Design B

BARRA MICROMETRICA @...

BMA-D03-220-15.5

X Inserts CC?3-060277N
CPM-001-C/ 836,55

Inserts CC73-060277N

You can review detailed tool data in the folder tabs Graphic, Data, and Cutting conditions:

| Graphic | Data |Cul'ting ccndi‘tions|

Diameter (0) 504
Dia step 1 (Da) ]
Collision Dia (The) [i]

If no TopSolid'Cam tool type has been previously assigned to the selected WinTool classification of the tool
assembly, you must do it now.
This will map the WinTool classification to the TopSolid'Cam tool type. Select the correct TopSolid'Cam tool

type from the selection list.
., ==

The current tool doesn't have a valid ToolStyle assigned. Please select one from the List below.

-
[@ Select Style:

616147 KAISER insert holder ENH32
Lollipop Mill -
Conic Nose Mil ) 120
Conic Nose Ball Mil
Spot Face Mil

Courterboring Mil

Comer Rounding Mill —
Chamfer Mill

Reverse Chamfer Mil

Double Chamfer Mill =
Disc: Mill

Radiused Staggered Teet
Constant Reamer 5
Boring Bar

Tap
Irtarnal Thraad Ml

-

[] Store in assigned Tool Class

If you select "Ignore" to assign to a tool classification, the tool assemblies in this classification will not be
transferred at all. This is useful for data that must not be transferred to TopSolid'Cam, e.g. measuring equip-
ment.

The tool assemblies are created in a library called "WinTool Tools". A reference to this library is added auto-
matically in the currently open machining project.

Corner Radius

As of WT-TopSolidCAM-Interface 1.4.3 it is possible to set the corner radius of the tool to "0" in WinTool. The
Interface will automatically import it as "0.001" into TopSolid as it is the minimum requirement for a correct
import.
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Assigning Tool Assemblies to a Pocket

Tool assemblies must be assigned to a pocket before they can be used in an operation. This can be
achieved via the tool selection in the operation definition or the tool manager.

Open the tool manager:
< Equipment ¥ g} 2D/31

PP |%] &

If you are using a mill-turn machine, you can filter the type of pockets displayed in the list:

All Tool Holders *

The pocket list is now displayed.
1. Select the tool type of the tool assembly you would like to assign to the pocket

2. Select the pocket where the tool assembly will be placed

Note: Each turret pocket has three pocket axis (Z+/X+/Z-). Pocket  Packet Axis
When importing a turning tool, select the correct one according to the turret E T z
T12 X+

type. X+ is the most frequently used. sz

3. Click on the "Import from catalog" button

= List tool
= 2 1
. . I T
‘ace Mill Side Mill Slet Mill TSlot Mill  Radiused M...
1 [ i |

Y

Pocket P. D L r
71 Z+ | 100mm Fmm Omm
T2 Z+ | 32mm 60mm Jmm
1113 Z+ | 12mm 35mm Omm
||:| Th Z+ | hmm F0mm Omm
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In the next window, if the "WinTool Tools" library is not active, click on the "Tools Library" button on the left

side and select "WinTool Tools" from the dropdown list.

-
&, Catalog(WinTool Tools, <25>)

WinTool Tools

616018 End Mill H55 2x7 76 | 2mm

v X ?

Note: In the "Catalogue filter" window, you can use the "Tooling system" filter to view all tool assemblies on

the selected WinTool machine type:

% Catalogue filter
[“IOperation filter

FunctionName="SlotMill’

Description:

O

ped

Tooling system:

03 Index - VDI-30
Cylindrical 30mm
Cylindrical 6mm
1SO

When you have found the tool assembly in the list, double-click to add it to the pocket.

Turning Tool Assembly Indexation Angle

When importing a turning tool assembly, you can change the indexation angle to change the orientation of
the tool assembly on the turret. Double click on the tool assembly and go to the "Tool assembly" tab. Change

the angle until the tool assembly is correctly placed:

f*g Components

Description

|636124 End Mill HSS 20x38 4FL

Component(s) Template(s) Info
Tool holder element

‘ Turret

Articulation

Qutput distance

10mm

i Indexation angle

180°

WT-TopSolidCam-Interface-Manual-E.docx 10.06.2021
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Export Tool List To WinTool

When you have finished the NC program, the list of all the tools used in the TopSolid'Cam project must be
stored back to WinTool. This will allow the next person in the production process to continue with the job.

Start the export by clicking on the WT-PUT button.

Edit the tool list header information:

WT-MakeList 3.9.5

List name  SideFrame NCP 1258-TER
Machine type 52 - DMU {SK40) O-Number

Description: StMr 1.0570

REEETEE General structural stesl

unalloyed more than 500 N/mm*

Select "OK" to store the information in the WinTool database.
If a tool list with the same List Name already exists in WinTool the following dialog box appears:

' l
WT-MakelList [

This tool list does already exist.
Do you want to overwrite it or do you want to add the tools?

[ Overwrite ] [ Add l l Cancel
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Preparing Tool Data in WinTool

For the WT-TopSolidCame-Interface to work properly WinTool component and assembly data must be rec-
orded correctly. WinTool resellers offer training courses to make sure that you are building a high-quality tool
database that is fit for engineering requirements.

However, the following points are prerequisite for the WT-TopSolidCam-Interface to work and will be de-
scribed in detall in the chapters below:

Each WinTool classification must be assigned to the corresponding TopSolidCam tool type.

Each tool assembly must be linked to a WinTool Machine Type.

Each tool assembly must have a "namegiving” and a "cutting” component.

The tool geometry must be recorded in WinTool with the correct tool type and outline (for details please
refer to the WinTool Professional documentation and the training course manuals).

Components that are used for turning tools must have STEP or STL models linked in the folder 3D:

2D 73D i|Outline| JPG | Shape |

STL = 0L L

A3D\Parts\ 1203 st

STEP = oL O

A3D\Parts\1203 step
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Grooving and Threading

Currently, for Grooving and Threading tools, some “corrections” are required so that these tools are imported
and created correctly.

In the current WinTool version, some new outlines are being created in the area of Groove-Thread-Turning.

These are:

External holder — right hand External insert - right hand ER

External holder - left hand External insert — left hand EL
Internal holder — right hand Internal insert — right hand IR
Internal holder — left hand Internal insert — left hand IL
External holder - U-Type External insert - U-Type
Internal holder - U-Type Internal insert - U-Type

Please see the outlines below and how to enter the data.

As far as holders as concerned, Li and Xi need to be measured from the reference point of the insert (zero-
point).

As far as inserts are concerned, only the profile distances (Xi neg and Li neg) need to be corrected. These
values depend on the thread pitch.

Important:
The parameters of the components need to be entered into WinTool as shown in the outlines below.

So, this is what the values should look like:

Li Xi
Holder right pos pos
Insert right neg neg
Holder left pos neg (Holder right mirrored around the X-axis)
Insert left neg pos (Insert right mirrored around the X-axis)
Outline for Reference Actual Outline
14-08 R ’y
N/

A61
A62
A4
\\//

S
v
il
s

f/ —
A 4 L 1
> . g
< AB1 M
A8 AB2 G4
o t >
o
Y V/
E7: R

WV WINTQOL

Please Use the Outline for Reference to create the parts in WinTool
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External insert right
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External holder right
Outline for Reference Actual Outline

- 14-08 ER | 15-22 R
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Gl « G _/
» ; Li — 14-5KJ
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i | Qv )
N4y L
—
(© winTool AG WV WINTCOL

Please Use the Outline for Reference to create the parts in WinTool
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Internal insert left
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Custom Tool Assembly Contour

If a contour of a tool assembly cannot be created automatically with the Shape-Generator, you can create
the DXF file manually.

e Open the tool assembly and use the Shape-Generator button to create a DXF contour. Even if a
tool is not supported fully by the Shape-Generator, it will create in most cases a contour-DXF,
although not with all additional details of the custom tool - but with a lot of useful elements in place al-
ready: holder, extensions, reductions, shank, total length, correct layers, etc.
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e Then modify it with Vector or any other DXF editor until it is exact. You must use the layers CUT,
NOCUT, and SHANK:

A —

Y

SHANK cut

NOCUT

s
X

e The CUT layer is independent from the shank and holder closed contour. It must start and end at the X-
axis (Y=0). Only the first and the last line of the contour are allowed to start/end at X-axis.

e The SHANK and NOCUT layer together must form a closed contour. It must start and end at the X-axis
(Y=0). Only the first and the last line of the contour are allowed to start/end at X-axis.

¢ When you have finished the modification, you must save the file in the User Models Path with the name
of the WinTool tool assembly Ident No (e.g. 616089.dxf). Already existing files must be overwritten.

e Assign the new DXF to the WinTool tool assembly: Check the box “User Model” in the tab “CAM” in the
row containing "TopSolidCam®. If it is missing, please activate TopSolidCam in "Settings" > "CAM set-
tings" on the main WinTool screen.

| Graphic I Geometry I AD I Bill of materals | CAM E

CAM name Transfemed | User Model |
TopSolidCAM 7

Special Tool Assembly 3D Models

You can create a 3D tool assembly model for the holder components (do not include the cutter) if you place a
STEP or STL file in the User Models Path. The model file must have the name of the WinTool tool assembly
Ident No (e.g. 616089. step). You must also set the check the box “User Model” in the tab “CAM” of the tool
assembly, see picture above.
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VWINTOOL

Software Structure

(" .
TopSolid'Cam

~

Database
Server
GET
WinTool
[7.*\WT-TopSolidCAM-GetTools.exe Sl
Base
[ WT-ToolExport.exe ]::);
G
< achin
< oolLis
sembli
_VVVV =
[7.*\WT-TopSolidCam-Interface.exe ¥
-
inTool Tool cfg
Library L ! Shape.exe }7
A
e N
OutputPath UserModels
Folder Folder
PUT v
l xyz.dxf
[WT-TopSoIidCam-PutTooIList.exe ] L
v WTMakelList.exe
cfg Lists
& VRN
_ L
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History
1.4.6

v
v

Compatible with WinTool 2020.3.1
Compatible with TopSolid 7.15

1.4.5

v
v

Compatible with WinTool 2020.2.1
Compatible with TopSolid 7.14

1.4.4

AN NI N N N N

AN

Compatible with WinTool 2019.1.2

Support of new Tool type “Back Spot Face Mill”

Support of new Tool type “External Thread Mill”

Support of new Tool type “Barrel Mill”

Support of new Tool type “Oval Mill”

Support of new Tool type “Lens Mill”

Added new configuration option:

v" “NCProgramNumber”

¥" “ToolListDescription”

v" “ImportToolsToPocket”

Fixed “special”’ characters that would appear sometimes when using PUT
Tool “Ball Touch” is now imported correctly

Added important information about Grooving-Threading-Turning Tools to the Manual

=
e
w

AN N U U N N N

Compatible with WinTool 2019.1

Compatible with TopSolid 7.13

Fixed zero Points that were wrongly Positioned for Imperial Milling Tools
Fixed Import of Tool Type “Ball Touch” (/TC30)

Fixed scaling of 3D Models from Imperial Tools

Fixed General conversion of Tools

Implemented new Licensing Model

Made it possible to Import Tools with corner radius 0

1.4.2

ANERN

ANANA NN Y

Compatible with WinTool 2018.2.1

Cutting Conditions Plugin changes:

v" Added Ap/Ae Values to Operation Settings (Available in TopSolid 7.12 SP9)

Fixed PUT where it wouldn’t work sometimes with certain Configurations

Fixed Import where Tools wouldn’t be imported if they were already imported in older Projects
Added STL Import for TopSolid 7.12

Support of new Tool type “Gun Drill”

Support of new Tool type “High Feed Face Mill”

Support of new Tool type “Countersink Drill”
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1.4.1

v
v

Compatible with WinTool 2018.2
Fixed Import of same Tool twice

1.4

v
v
v

AN N N N N

Compatible with WinTool 2018.1

Compatible with TopSolid 7.11 and 7.12

WinTool MakeList changes:

¥v" Machine name is now being exported and if available in WinTool automatically selected
v" Project name is now automatically the Tool List name

Corrected conversion of Inch and Metric tools when imported to a different unit system
Made T-Number and ToollD configurable

OldName is now imported in the “Comment” field

Fixed Insert of Type T

Added plugin for Cutting Conditions

1.3.2

v

Corrected error when importing turning tools in Versions above TopSolid'‘Cam 7.11.300.0

1.3.1

v
v

Corrected error when importing tools in TopSolid'Cam 7.11
Added shortcut to interface configuration window

1.3

v
v
v
v

D N N N e

LA P

Compatible with TopSolid'Cam 7.11

Added support for flat drill tools

Corrected import of tool offset values for chamfer mill, face mill and corner rounding mill
Adjusted import of chamfer mill to work with graving tool

2

Compatible with TopSolid'Cam 7.10

Added support for turning tools

Added 3D model holder import for radial milling and drilling tools

Importing WinTool machine type name to enable filtering in tool search window

i

Compatible with TopSolid'‘Cam 7.8 and 7.9

Importing tool assemblies into "WinTool Tools" library instead of current project
Corrected center drill import

Corrected pocket number extraction in tool list export
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