WT-TopSolidCam
Interface

WinTool Interface for TopSolid'Cam 7.8/7.9

The WT-TopSolidCam-Interface enables the user to select and transfer tool assemblies
from the WinTool database to the TopSolid'Cam environment.

After production of a NC program, a complete list of the tools used in the NC-Program
will be stored back to the WinTool database for further processing in the company.

Requirements
e WinTool 2011 Professional or newer
e TopSolid'Cam 7.8 with update 7.8.303.100 or newer or 7.9
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Summary
Job

The WT-TopSolidCam-Interface enables the user to export all assemblies from the WinTool database into
the TopSolid environment. Full graphic representation with tool holders and extensions are supported.

After production of a NC program, a complete list of the tools used in the NC-Program will be stored back to
the WinTool database for further processing in the company.

Requirements

This Interface requires WinTool Professional 2011 or newer. TopSolid'‘Cam 7.8 and 7.9 are supported.
For TopSolid'Cam 7.8 the update 7.8.303.100 or newer is required.

Licensing

You need a license agreement with WinTool AG, Switzerland.

Limitations

No turning tools can be transferred with this interface version.

Copyright

This documentation as well as the Software itself is under copyright of

WinTool AG

Fluelastrasse 7

CH-8048 Ziirich

Phone: +41 (0)44 401 00 55
info@wintool.com
http://www.wintool.com
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Installation

Directory Structure

All user data is centrally placed the [Public Documents]\WT-TopSolidCam-Interface folder:

User data Location

Default location of UserModels [Public Documents]\WT-TopSolidCam-Interface\UserModels
folder

Default location of Exchange folder | [Public Documents]\WT-TopSolidCam-Interface\Exchange
Configuration file [Public Documents]\WT-TopSolidCam-Interface
WT-TopSolidCam-Interface.cfg

Note: [Public Documents] on Windows XP is located in C:\Documents and Settings\All Us-
ers\Documents on Windows Vista and newer in C:\Users\Public\Documents\

New Installation

Log on with administrator rights to install the software on a PC. Install WinTool Professional first before you
install the WT-TopSolidCam-Interface.

Download the latest WT-TopSolidCam-Interface software release from www.WinTool.com and start Set-
up.exe.

Follow the instructions in chapter Configure WT-TopSolidCam-Interface and Configure TopSolid'Cam

Update

Download the latest WT-TopSolidCam-Interface software release from www.WinTool.com and start Set-
up.exe.

Follow the instructions in chapter Configure TopSolid'Cam

Open the interface configuration via "Start" > "All Programs" > "WinTool" > "WT-TopSolidCam-Interface" >
"WT-TopSolidCam-Interface Configuration” and check the settings.
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Configure WT-TopSolidCam-Interface

The configuration window allows you to check and change the settings of the WT-TopSolidCam-Interface.
Open the configuration window via "Start" > "All Programs” > "WinTool" > "WT-TopSolidCam-Interface ..."
> WT-TopSolidCam Configuration"

Path settings: Click on
f .
WT-TepSolidCam-Interface Configuraticn L = the icon to select a
directory via browser or
Settings / enter path manually
Name Walue /
Oupapan | ]
UserModels Path D:NCAMY

Settings not with de- / . .
The error icon & indi-

fault values are white. :

Settings with default cates a faulty value in

values are gray the cfg file. If it appears
the setting must be

) ) checked
Details on selected setting
Default OutputPath is "Exchange” folder in local path
Comments /
about the data
field settings 0K || Cancel
& = ——

<OK> stores all settings. <Cancel> exits the configuration window without saving.

The configuration window reads and stores settings in the file “WT-TopSolidCam-Interface.cfg” which is lo-
cated in the directory [Public Documents]\WT-TopSolidCam-Interface. This file can also be edited
with a text editor.

Output Path
The Output Path defines the directory for the data exchanges.

This directory must not be shared by multiple users because the data transferred via this directory is NC
project specific and temporary only.

The default settings are:
OutputPath = [Public Documents]\WT-TopSolidCam-Interface\Exchange\

UserModels Path

The UserModels directory manages the transfer of tool contour graphics (DXF). WinTool links and manages
these models and all NC programmers must access and share this data.

If you have multiple NC programmers you must create a UserModels folder on the server. It must be includ-
ed in the backup schedule.

The default settings are:
UserModelsPath = [Public Documents]\WT-TopSolidCam-Interface\UserModels\
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Configure TopSolid'Cam

To access the WT-TopSolidCam import and export quickly, add the buttons to TopSolid'Cam:
e Open a machining project in TopSolid'Cam
e Select "Tools" > "Customize"

Import Button

1. In"Add a file to execute", click on "..."
TopSolid 7.8
- Go to the WT-TopSolidCam-Interface installation directory and open the directory "7.8"
- Select "WT-TopSolidCAM-GetTools.exe"
TopSolid 7.9
- Go to the WT-TopSolidCam-Interface installation directory and open the directory "7.9"
- Select "WT-TopSolidCAM-GetTools.exe"

2. Drag and Drop the "WT-GET" icon into a toolbar "Equipment"”

Export Button

1. In"Add afile to execute", click on "..."
TopSolid 7.8
- Go to the WT-TopSolidCam-Interface installation directory and open the directory "7.8"
- Select "WT-TopSolidCAM-PutToolList.exe"
TopSolid 7.9
- Go to the WT-TopSolidCam-Interface installation directory and open the directory "7.9"
- Select "WT-TopSolidCAM-PutToolList.exe"

2. Drag and Drop the "WT-PUT" icon into the toolbar "Equipment"

® Home | -3 Equipment ¥ ] 2D/3D & | 1, 4D/5D ¥ e Tuming ¥ @] Additional % | %¥Operation ¥ ] Verify  ImalVisualization §

4dANES & D2

NC Operations [y [Start Page BWintool-TopSolid-Denw-Start—l-Result

@Customize
| Toolbars || Shortcut keys ,\

Drag-and-drop commands between th\toolbars, or from the lists below..

Command category:

’AII Categories - Add user context

Add commands:

- Right-cli
(43D Contouring... (2D/3D) rename it

- 4X Radial Roughing... (4D/5D) Drag-and-dm\p a user context to change its position.
£/] 5D Contouring... (4D/5D)
"/ About TopSalid... (Global)
T Add-ins... (Operation) Rolling lists
T Add-ins... (Tools) o
] Adjust Continuity... (Surface » ¢ A~dd rollinglist
-+ Alignment.. (30 Sketch > Const D
++ Alignment... (20 Sketch > Const

7, Ambient Light... (Visualization >
i Analysis of drillings and cylinde Add a file to execute
[] Analyze Area Moments of Inerti;
#r Analyze Continuity... (Tools » 4| Path of file to execute:
_"‘}';' Analyze Curvature... (Tools » Ar
??Analyze Enumeration... (Tools »
&% Analyze Face Type... (Tools > Ar
7 Analyze Geomnetry... (Tools > Ar
L Analyze Normal... (Tools > Anal
% Analyze Physical Properties... (Ty
??%Analyze User Enumeration... (To

a user context to modify its icon/name, double-click to

Separators
Add separator:

)

Interface\ WT-ToolExport.exe

Command name: WT-ToolExport

Drag-and-drop icon:

Display commands on document
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Supported TopSolid'Cam Tool Types

Each tool classification in WinTool must be assigned to the corresponding TopSolid'Cam tool type.
This is done automatically when you import tool assemblies.

You can modify the assignment manually:
In WinTool select Settings > Class, then select a classification. In the data field "Note" you can assign the

corresponding TopSolid'Cam tool type.
[@ Classes

Search by
| Cassification | Description |

Description |422 countersinks |

Codesfor CAM |[/VCO1/CA14/TC19 |

Assigned to | 42 counterbore | - |

Example: For the classification "422 countersinks" assign the tool type /TC19.

TopSolid'Cam Tooltype WinTool
English Classification
Spotting Drill /TCO1
Center Dirill /TCO02
Twist Drill /TCO3
Face Mill /TCO06
Side Mill /TCO7
Slot Mill /TCO08
T Slot Mill /TCO09
Radiused Mill /TC10
BallNose Mill /TC11
Lollipop Mill /TC12
Conic Nose Mill /TC13
Conic Nose Ball Mill /TC14
Spot Face Mill /TC15
Counterboring Mill /TC17
Corner Rounding Mill /TC18
Chamfer Mill /TC19
Reverse Chamfer Mill /TC20
Double Chamfer Mill /TC21
Disc Mill /TC22
Radiused Staggered Teeth Mill /TC23
Constant Reamer /ITC25
Boring Bar /TC26
Tap ITC27
Internal Thread Mill /TC29
BallTouch /TC30
Ignore /TCO0

WinTool classifications mapped to /TC0O0 are ignored. This means that tools assigned to this classification
are not transferred to TopSolid'Cam. This is useful for measurement equipment, fixtures, etc.
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WinTool

Importing Tool Assemblies

Note: The "TopSolid Machining" library must be in the PDM.

Open a machining project. Start the import by clicking on the WT-GET button.

The following WT-ToolExport menu will open:

-
GET]

WT-ToolExport

Tool list

Tool assembly

Machine

o

& W

Select the icon for tool assembly to import tools individually or for tool list to load an existing WinTool tool list.

If you know the tool assembly ID or tool list name, you can

The tools will immediately be transferred. Click on to
light the desired tool.

fill in the value and hit enter on your keyboard.

open the tool classification tree. Select and high-

g B
(@ Search for assembly EIM
221 face mil - = Machine type Al
State Al
With cutting conditions for | 712 Aluminium “ Wrough alloy not aged Al
Only
I prered
DMC Clength CRadius Chrc LColl  ID & Descript Design
50 10 05 43 70 oy S face mil R220.43 50mm OFEX 05T305
a5 1] i
43 0
25 0
100 7 05 43 ] 616093 face mil RZ‘ZD sQqy OFEX 057305 I
100 15 3 85 ] 616094 end mill edging R220.63 = = B
50 15 3 25 70 §16095 end mill edging Rzzoeasr Class B
Graphic | Data | Cutting conditions Select one from each list
1_drilling 21 end mil 221 face mil
150 T — 222 square shoulder cutter
3 tap 24 other mills 223 chamfer mill
130.9 4 reamer, ¢ bore 25 inch end mil 224 disc mil
5 modular system 26 inch insert mill
& tuming tool 27 inch other mills
7 inserts
8 haolder
9 other
A measuring equip.
B clamping equip.
I c
i
o
= T \ ‘
(S

There are filters available for machine type, tool data release state, cutting conditions for different materials,
and preferred tools. You can also enter commands (>, <, >=, <=) to filter a list of tools:

- [+
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The function turns on combo box selection for the tool values:

DMC [¢] CL.. [¢] CR.. [¢] CAc [¢] LColl [¢] ID [+] Descript [+] Design [« *
BARRA MICROMETRICA @...

224 0 0 180 70 500058 BMA-003-220-15.5 Inserts CC?3-060272N =

355 |0 0 180 51 500062 CPM-001C/ @36.55 Inserts CC?3-060277N

You can review detailed tool data in the folder tabs Graphic, Data, and Cutting conditions:

| Graphic | Data |Cul'ting ccndi‘tions|

Diameter (0) 504
Dia step 1 (Da) ]
Collision Dia (The) [i]

If no TopSolid'Cam tool type has been previously assigned to the selected WinTool classification of the tool
assembly, you must do it now.

This will map the WinTool classification to the TopSolid'Cam tool type. Select the correct TopSolid'Cam tool
type from the selection list.

e . =

The current tool doesn't have a valid ToolStyle assigned. Please select one from the List below.

616147 KAISER insert holder ENH32

Lollipop Mill

Conic Nose Mil

Conic Nose Ball Mil

Spot Face Mil
Courterboring Mil

Comer Rounding Mill
Chamfer Mill

Reverse Chamfer Mil
Double Chamfer Mil

Disc: Mill

Radiused Staggered Teet
Constant Reamer 4
Boring Bar

Tap
Ir#armal Thrasd Mil

-

[] Store in assigned Tool Class

If you select "Ignore" to assign to a tool classification, the tool assemblies in this classification will not be
transferred at all. This is useful for data that must not be transferred to TopSolid'Cam, e.g. measuring
equipment.

The tool assemblies are created in a library called "WinTool Tools". A reference to this library is added auto-
matically in the currently open machining project.
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Assigning Tool Assemblies to a Pocket

Tool assemblies must be assigned to a pocket before they can be used in an operation. This can be
achieved via the tool selection in the operation definition or the tool manager.

The pocket list is now displayed.
1. Select the tool type of the tool assembly you would like to assign to the pocket
2. Select the pocket where the tool assembly will be placed
3. Click on the "Import from catalog" button

‘2 List tool
}

‘ace Mill Side Mill TSlot Mill  Radiused M.,
‘ | |
.m

Pocket P.. D L r
T1 Z+ | 100mm Fmm Omm
T2 Z+ | 32mm 60mm 3mm
T3 Z+ | 12mm 35mm Omm:
T4 2 | Z+  10mm 35mm Omm
T5 7+ |5mm 70mm Omm

In the next window, if the "WinTool Tools" library is not active, click on the "Tools Library" button on the left
side and select "WinTool Tools" from the dropdown list.

-
£, Catalog{WinTool Tools,<2>) E=E

v X?

Double-click on the tool assembly you would like to add to the pocket.
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Export Tool List To WinTool

When you have finished the NC program, the list of all the tools used in the TopSolid'Cam project must be
stored back to WinTool. This will allow the next person in the production process to continue with the job.

Start the export by clicking on the WT-PUT button.

Edit the tool list header information:

WinTool

WT-MakeList 3.9.5

List name  SideFrame NCP 1258-TER
Machine type 52 - DMU {SK40) O-Number

Description: StMr 1.0570

REEETEE General structural stesl

unalloyed more than 500 N/mm?

Select "OK" to store the information in the WinTool database.
If a tool list with the same List Name already exists in WinTool the following dialog box appears:

' Y
WT-MakelList S

This tool list does already exist.
Do you want to overwrite it or do you want to add the tools?

I Overwrite ] [ Add l l Cancel
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Custom Tool Assembly Contour

If a contour of a tool assembly cannot be created automatically with the Shape-Generator, you can create
the DXF file manually.

e Open the tool assembly and use the Shape-Generator button to create a DXF contour. Even if a
tool is not supported fully by the Shape-Generator, it will create in most cases a contour-DXF,
although not with all additional details of the custom tool - but with a lot of useful elements in place al-
ready: holder, extensions, reductions, shank, total length, correct layers, etc.

e Then modify it with Vector or any other DXF editor until it is exact. You must use the layers CUT,
NOCUT, and SHANK:

e

Y

SHANK cut

NOCUT

L
X

e The CUT layer is independent from the shank and holder closed contour. It must start and end at the X-
axis (Y=0). Only the first and the last line of the contour are allowed to start/end at X-axis.

e The SHANK and NOCUT layer together must form a closed contour. It must start and end at the X-axis
(Y=0). Only the first and the last line of the contour are allowed to start/end at X-axis.

¢ When you have finished the modification, you must save the file in the User Models Path with the name
of the WinTool tool assembly Ident No (e.g. 616089.dxf). Already existing files must be overwritten.

e Assign the new DXF to the WinTool tool assembly: Check the box “User Model” in the tab “CAM” in the
row containing "TopSolidCam". If it is missing, please activate TopSolidCam in "Settings" > "CAM set-
tings" on the main WinTool screen.

| Graphic | Geometry | AD | Bl of materials | CAM | Pr

CAM name Transfemed | User Model §
TopSclidCAM =
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WinToo/ B

Software Structure

-
TopSolid'Cam - <
Database
Server
GET
WinTool
( * i Data
[7.*\WT-TopSolidCAM-GetTools.exe
Base
N
< achin
< oolLis
sembli
[7.*\WT-TopSolidCam-Interface.exe ol-Cla
inTool Too cfg
Library L ! Shape.exe P
A
e N N
OutputPath UserMode|s
Folder Folder
A 4
xyz.dxf
[WT-TopSoIidCam-PutTooIList.exe ] L )
v WTMakeList.exe
cfg Lists
& J J
o ) L )
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History
1.1

Compatible with TopSolid'Cam 7.8 and 7.9

Compatible with WinTool 2011 — 2015

Importing tool assemblies into "WinTool Tools" library instead of current project
Corrected center drill import

Corrected pocket number extraction in tool list export

A NI N N N
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